Intel security is compromised big time
Published in Processors


Vulnerability level similar to Heartbleed (OpenSSL) in 2014

Intel has just patched a security vulnerability that affects all of its desktop and notebook platforms from Nehalem in 2008 to Kaby Lake in 2017, with a higher degree of vulnerability for users on Intel vPro systems.

19 July 2010

Rugged tablet out

y_exclamation

iPad not hard enough